working with gitlab

[root@git ~]# yum install curl openssh-server postfix cronie
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: centos.mirror.nac.net
* epel: mirror.us.leaseweb.net
* extras: mirror.cc.columbia.edu
* updates: mirror.trouble-free.net
Package 2:postfix-2.10.1-6.el7.x86_64 already installed and latest version
Package cronie-1.4.11-14.el7_2.1.x86_64 already installed and latest version
Resolving Dependencies
–> Running transaction check
—> Package curl.x86_64 0:7.29.0-25.el7.centos will be updated
—> Package curl.x86_64 0:7.29.0-35.el7.centos will be an update
–> Processing Dependency: libcurl = 7.29.0-35.el7.centos for package: curl-7.29.0-35.el7.centos.x86_64
—> Package openssh-server.x86_64 0:6.6.1p1-25.el7_2 will be updated
—> Package openssh-server.x86_64 0:6.6.1p1-31.el7 will be an update
–> Processing Dependency: openssh = 6.6.1p1-31.el7 for package: openssh-server-6.6.1p1-31.el7.x86_64
–> Running transaction check
—> Package libcurl.x86_64 0:7.29.0-25.el7.centos will be updated
—> Package libcurl.x86_64 0:7.29.0-35.el7.centos will be an update
—> Package openssh.x86_64 0:6.6.1p1-25.el7_2 will be updated
–> Processing Dependency: openssh = 6.6.1p1-25.el7_2 for package: openssh-clients-6.6.1p1-25.el7_2.x86_64
—> Package openssh.x86_64 0:6.6.1p1-31.el7 will be an update
–> Running transaction check
—> Package openssh-clients.x86_64 0:6.6.1p1-25.el7_2 will be updated
—> Package openssh-clients.x86_64 0:6.6.1p1-31.el7 will be an update
–> Processing Conflict: openssh-6.6.1p1-31.el7.x86_64 conflicts selinux-policy < 3.13.1-92
–> Restarting Dependency Resolution with new changes.
–> Running transaction check
—> Package selinux-policy.noarch 0:3.13.1-60.el7_2.9 will be updated
–> Processing Dependency: selinux-policy = 3.13.1-60.el7_2.9 for package: selinux-policy-targeted-3.13.1-60.el7_2.9.noarch
–> Processing Dependency: selinux-policy = 3.13.1-60.el7_2.9 for package: selinux-policy-targeted-3.13.1-60.el7_2.9.noarch
—> Package selinux-policy.noarch 0:3.13.1-102.el7_3.7 will be an update
–> Processing Dependency: policycoreutils >= 2.5 for package: selinux-policy-3.13.1-102.el7_3.7.noarch
–> Processing Dependency: libsemanage >= 2.5 for package: selinux-policy-3.13.1-102.el7_3.7.noarch
–> Running transaction check
—> Package libsemanage.x86_64 0:2.1.10-18.el7 will be updated
–> Processing Dependency: libsemanage = 2.1.10-18.el7 for package: libsemanage-python-2.1.10-18.el7.x86_64
—> Package libsemanage.x86_64 0:2.5-4.el7 will be an update
—> Package policycoreutils.x86_64 0:2.2.5-20.el7 will be updated
–> Processing Dependency: policycoreutils = 2.2.5-20.el7 for package: policycoreutils-python-2.2.5-20.el7.x86_64
—> Package policycoreutils.x86_64 0:2.5-9.el7 will be an update
—> Package selinux-policy-targeted.noarch 0:3.13.1-60.el7_2.9 will be updated
—> Package selinux-policy-targeted.noarch 0:3.13.1-102.el7_3.7 will be an update
–> Running transaction check
—> Package libsemanage-python.x86_64 0:2.1.10-18.el7 will be updated
—> Package libsemanage-python.x86_64 0:2.5-4.el7 will be an update
—> Package policycoreutils-python.x86_64 0:2.2.5-20.el7 will be updated
—> Package policycoreutils-python.x86_64 0:2.5-9.el7 will be an update
–> Processing Dependency: setools-libs >= 3.3.8-1 for package: policycoreutils-python-2.5-9.el7.x86_64
–> Running transaction check
—> Package setools-libs.x86_64 0:3.3.7-46.el7 will be updated
—> Package setools-libs.x86_64 0:3.3.8-1.1.el7 will be an update
–> Finished Dependency Resolution

Dependencies Resolved

================================================================================================================================================
Package Arch Version Repository Size
================================================================================================================================================
Updating:
curl x86_64 7.29.0-35.el7.centos base 265 k
openssh-server x86_64 6.6.1p1-31.el7 base 439 k
selinux-policy noarch 3.13.1-102.el7_3.7 updates 412 k
Updating for dependencies:
libcurl x86_64 7.29.0-35.el7.centos base 218 k
libsemanage x86_64 2.5-4.el7 base 144 k
libsemanage-python x86_64 2.5-4.el7 base 103 k
openssh x86_64 6.6.1p1-31.el7 base 437 k
openssh-clients x86_64 6.6.1p1-31.el7 base 642 k
policycoreutils x86_64 2.5-9.el7 updates 841 k
policycoreutils-python x86_64 2.5-9.el7 updates 444 k
selinux-policy-targeted noarch 3.13.1-102.el7_3.7 updates 6.4 M
setools-libs x86_64 3.3.8-1.1.el7 base 612 k

Transaction Summary
================================================================================================================================================
Upgrade 3 Packages (+9 Dependent packages)

Total download size: 11 M
Is this ok [y/d/N]: y
Downloading packages:
Delta RPMs disabled because /usr/bin/applydeltarpm not installed.
(1/12): libsemanage-python-2.5-4.el7.x86_64.rpm | 103 kB 00:00:00
(2/12): libsemanage-2.5-4.el7.x86_64.rpm | 144 kB 00:00:00
(3/12): libcurl-7.29.0-35.el7.centos.x86_64.rpm | 218 kB 00:00:00
(4/12): curl-7.29.0-35.el7.centos.x86_64.rpm | 265 kB 00:00:00
(5/12): openssh-6.6.1p1-31.el7.x86_64.rpm | 437 kB 00:00:00
(6/12): openssh-server-6.6.1p1-31.el7.x86_64.rpm | 439 kB 00:00:00
(7/12): openssh-clients-6.6.1p1-31.el7.x86_64.rpm | 642 kB 00:00:00
(8/12): policycoreutils-2.5-9.el7.x86_64.rpm | 841 kB 00:00:00
(9/12): policycoreutils-python-2.5-9.el7.x86_64.rpm | 444 kB 00:00:00
(10/12): selinux-policy-3.13.1-102.el7_3.7.noarch.rpm | 412 kB 00:00:00
(11/12): setools-libs-3.3.8-1.1.el7.x86_64.rpm | 612 kB 00:00:01
(12/12): selinux-policy-targeted-3.13.1-102.el7_3.7.noarch.rpm | 6.4 MB 00:00:01
————————————————————————————————————————————————
Total 3.6 MB/s | 11 MB 00:00:02
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
Updating : libsemanage-2.5-4.el7.x86_64 1/24
Updating : policycoreutils-2.5-9.el7.x86_64 2/24
Updating : openssh-6.6.1p1-31.el7.x86_64 3/24
Updating : selinux-policy-3.13.1-102.el7_3.7.noarch 4/24
Updating : libsemanage-python-2.5-4.el7.x86_64 5/24
Updating : setools-libs-3.3.8-1.1.el7.x86_64 6/24
Updating : libcurl-7.29.0-35.el7.centos.x86_64 7/24
Updating : curl-7.29.0-35.el7.centos.x86_64 8/24
Updating : policycoreutils-python-2.5-9.el7.x86_64 9/24
Updating : selinux-policy-targeted-3.13.1-102.el7_3.7.noarch 10/24
warning: /etc/selinux/targeted/seusers created as /etc/selinux/targeted/seusers.rpmnew
‘/etc/selinux/targeted/modules/active/seusers’ -> ‘/etc/selinux/targeted/active/seusers.local’
Updating : openssh-server-6.6.1p1-31.el7.x86_64 11/24
Updating : openssh-clients-6.6.1p1-31.el7.x86_64 12/24
Cleanup : selinux-policy-targeted-3.13.1-60.el7_2.9.noarch 13/24
warning: /etc/selinux/targeted/modules/active/seusers.final saved as /etc/selinux/targeted/modules/active/seusers.final.rpmsave
Cleanup : policycoreutils-python-2.2.5-20.el7.x86_64 14/24
Cleanup : selinux-policy-3.13.1-60.el7_2.9.noarch 15/24
Cleanup : policycoreutils-2.2.5-20.el7.x86_64 16/24
Cleanup : libsemanage-python-2.1.10-18.el7.x86_64 17/24
Cleanup : openssh-clients-6.6.1p1-25.el7_2.x86_64 18/24
Cleanup : curl-7.29.0-25.el7.centos.x86_64 19/24
Cleanup : openssh-server-6.6.1p1-25.el7_2.x86_64 20/24
Cleanup : openssh-6.6.1p1-25.el7_2.x86_64 21/24
Cleanup : libcurl-7.29.0-25.el7.centos.x86_64 22/24
Cleanup : libsemanage-2.1.10-18.el7.x86_64 23/24
Cleanup : setools-libs-3.3.7-46.el7.x86_64 24/24
Verifying : selinux-policy-3.13.1-102.el7_3.7.noarch 1/24
Verifying : libsemanage-python-2.5-4.el7.x86_64 2/24
Verifying : openssh-server-6.6.1p1-31.el7.x86_64 3/24
Verifying : policycoreutils-2.5-9.el7.x86_64 4/24
Verifying : selinux-policy-targeted-3.13.1-102.el7_3.7.noarch 5/24
Verifying : libcurl-7.29.0-35.el7.centos.x86_64 6/24
Verifying : curl-7.29.0-35.el7.centos.x86_64 7/24
Verifying : policycoreutils-python-2.5-9.el7.x86_64 8/24
Verifying : openssh-6.6.1p1-31.el7.x86_64 9/24
Verifying : openssh-clients-6.6.1p1-31.el7.x86_64 10/24
Verifying : libsemanage-2.5-4.el7.x86_64 11/24
Verifying : setools-libs-3.3.8-1.1.el7.x86_64 12/24
Verifying : curl-7.29.0-25.el7.centos.x86_64 13/24
Verifying : openssh-server-6.6.1p1-25.el7_2.x86_64 14/24
Verifying : openssh-6.6.1p1-25.el7_2.x86_64 15/24
Verifying : libsemanage-python-2.1.10-18.el7.x86_64 16/24
Verifying : selinux-policy-3.13.1-60.el7_2.9.noarch 17/24
Verifying : policycoreutils-2.2.5-20.el7.x86_64 18/24
Verifying : libsemanage-2.1.10-18.el7.x86_64 19/24
Verifying : libcurl-7.29.0-25.el7.centos.x86_64 20/24
Verifying : setools-libs-3.3.7-46.el7.x86_64 21/24
Verifying : selinux-policy-targeted-3.13.1-60.el7_2.9.noarch 22/24
Verifying : openssh-clients-6.6.1p1-25.el7_2.x86_64 23/24
Verifying : policycoreutils-python-2.2.5-20.el7.x86_64 24/24

Updated:
curl.x86_64 0:7.29.0-35.el7.centos openssh-server.x86_64 0:6.6.1p1-31.el7 selinux-policy.noarch 0:3.13.1-102.el7_3.7

Dependency Updated:
libcurl.x86_64 0:7.29.0-35.el7.centos libsemanage.x86_64 0:2.5-4.el7 libsemanage-python.x86_64 0:2.5-4.el7
openssh.x86_64 0:6.6.1p1-31.el7 openssh-clients.x86_64 0:6.6.1p1-31.el7 policycoreutils.x86_64 0:2.5-9.el7
policycoreutils-python.x86_64 0:2.5-9.el7 selinux-policy-targeted.noarch 0:3.13.1-102.el7_3.7 setools-libs.x86_64 0:3.3.8-1.1.el7

Complete!

[root@git ~]# service postfix start
Redirecting to /bin/systemctl start postfix.service

[root@git ~]# wget https://packages.gitlab.com/install/repositories/gitlab/gitlab-ce/script.rpm.sh
–2016-12-21 10:33:10– https://packages.gitlab.com/install/repositories/gitlab/gitlab-ce/script.rpm.sh
Resolving packages.gitlab.com (packages.gitlab.com)… 54.153.54.194
Connecting to packages.gitlab.com (packages.gitlab.com)|54.153.54.194|:443… connected.
HTTP request sent, awaiting response… 200 OK
Length: unspecified [text/install_instructions]
Saving to: ‘script.rpm.sh’

[ <=> ] 6,371 –.-K/s in 0s

2016-12-21 10:33:10 (81.2 MB/s) – ‘script.rpm.sh’ saved [6371]

[root@git ~]# cat script.rpm.sh
#!/bin/bash

unknown_os ()
{
echo “Unfortunately, your operating system distribution and version are not supported by this script.”
echo
echo “You can override the OS detection by setting os= and dist= prior to running this script.”
echo “You can find a list of supported OSes and distributions on our website: https://packages.gitlab.com/docs#os_distro_version&#8221;
echo
echo “For example, to force CentOS 6: os=el dist=6 ./script.sh”
echo
echo “Please email support@packagecloud.io and let us know if you run into any issues.”
exit 1
}

curl_check ()
{
echo “Checking for curl…”
if command -v curl > /dev/null; then
echo “Detected curl…”
else
echo “Installing curl…”
yum install -d0 -e0 -y curl
fi
}
detect_os ()
{
if [[ ( -z “${os}” ) && ( -z “${dist}” ) ]]; then
if [ -e /etc/os-release ]; then
. /etc/os-release
os=${ID}
if [ “${os}” = “poky” ]; then
dist=`echo ${VERSION_ID}`
elif [ “${os}” = “sles” ]; then
dist=`echo ${VERSION_ID}`
elif [ “${os}” = “opensuse” ]; then
dist=`echo ${VERSION_ID}`
else
dist=`echo ${VERSION_ID} | awk -F ‘.’ ‘{ print $1 }’`
fi

elif [ `which lsb_release 2>/dev/null` ]; then
# get major version (e.g. ‘5’ or ‘6’)
dist=`lsb_release -r | cut -f2 | awk -F ‘.’ ‘{ print $1 }’`

# get os (e.g. ‘centos’, ‘redhatenterpriseserver’, etc)
os=`lsb_release -i | cut -f2 | awk ‘{ print tolower($1) }’`

elif [ -e /etc/oracle-release ]; then
dist=`cut -f5 –delimiter=’ ‘ /etc/oracle-release | awk -F ‘.’ ‘{ print $1 }’`
os=’ol’

elif [ -e /etc/fedora-release ]; then
dist=`cut -f3 –delimiter=’ ‘ /etc/fedora-release`
os=’fedora’

elif [ -e /etc/redhat-release ]; then
os_hint=`cat /etc/redhat-release | awk ‘{ print tolower($1) }’`
if [ “${os_hint}” = “centos” ]; then
dist=`cat /etc/redhat-release | awk ‘{ print $3 }’ | awk -F ‘.’ ‘{ print $1 }’`
os=’centos’
elif [ “${os_hint}” = “scientific” ]; then
dist=`cat /etc/redhat-release | awk ‘{ print $4 }’ | awk -F ‘.’ ‘{ print $1 }’`
os=’scientific’
else
dist=`cat /etc/redhat-release | awk ‘{ print tolower($7) }’ | cut -f1 –delimiter=’.’`
os=’redhatenterpriseserver’
fi

else
aws=`grep -q Amazon /etc/issue`
if [ “$?” = “0” ]; then
dist=’6′
os=’aws’
else
unknown_os
fi
fi
fi

if [[ ( -z “${os}” ) || ( -z “${dist}” ) ]]; then
unknown_os
fi

# remove whitespace from OS and dist name
os=”${os// /}”
dist=”${dist// /}”

echo “Detected operating system as ${os}/${dist}.”
}

finalize_yum_repo ()
{
echo “Installing pygpgme to verify GPG signatures…”
yum install -y pygpgme –disablerepo=’gitlab_gitlab-ce’
pypgpme_check=`rpm -qa | grep -qw pygpgme`
if [ “$?” != “0” ]; then
echo
echo “WARNING: ”
echo “The pygpgme package could not be installed. This means GPG verification is not possible for any RPM installed on your system. ”
echo “To fix this, add a repository with pygpgme. Usualy, the EPEL repository for your system will have this. ”
echo “More information: https://fedoraproject.org/wiki/EPEL#How_can_I_use_these_extra_packages.3F&#8221;
echo

# set the repo_gpgcheck option to 0
sed -i” ‘s/repo_gpgcheck=1/repo_gpgcheck=0/’ /etc/yum.repos.d/gitlab_gitlab-ce.repo
fi

echo “Installing yum-utils…”
yum install -y yum-utils –disablerepo=’gitlab_gitlab-ce’
yum_utils_check=`rpm -qa | grep -qw yum-utils`
if [ “$?” != “0” ]; then
echo
echo “WARNING: ”
echo “The yum-utils package could not be installed. This means you may not be able to install source RPMs or use other yum features.”
echo
fi

echo “Generating yum cache for gitlab_gitlab-ce…”
yum -q makecache -y –disablerepo=’*’ –enablerepo=’gitlab_gitlab-ce’
}

finalize_zypper_repo ()
{
zypper –gpg-auto-import-keys refresh gitlab_gitlab-ce
}

main ()
{
detect_os
curl_check
yum_repo_config_url=”https://packages.gitlab.com/install/repositories/gitlab/gitlab-ce/config_file.repo?os=${os}&dist=${dist}&source=script”

if [ “${os}” = “sles” ] || [ “${os}” = “opensuse” ]; then
yum_repo_path=/etc/zypp/repos.d/gitlab_gitlab-ce.repo
else
yum_repo_path=/etc/yum.repos.d/gitlab_gitlab-ce.repo
fi

echo “Downloading repository file: ${yum_repo_config_url}”

curl -sSf “${yum_repo_config_url}” > $yum_repo_path
curl_exit_code=$?

if [ “$curl_exit_code” = “22” ]; then
echo
echo
echo -n “Unable to download repo config from: ”
echo “${yum_repo_config_url}”
echo
echo “This usually happens if your operating system is not supported by ”
echo “packagecloud.io, or this script’s OS detection failed.”
echo
echo “You can override the OS detection by setting os= and dist= prior to running this script.”
echo “You can find a list of supported OSes and distributions on our website: https://packages.gitlab.com/docs#os_distro_version&#8221;
echo
echo “For example, to force CentOS 6: os=el dist=6 ./script.sh”
echo
echo “If you are running a supported OS, please email support@packagecloud.io and report this.”
[ -e $yum_repo_path ] && rm $yum_repo_path
exit 1
elif [ “$curl_exit_code” = “35” ]; then
echo
echo “curl is unable to connect to packagecloud.io over TLS when running: ”
echo ” curl ${yum_repo_config_url}”
echo
echo “This is usually due to one of two things:”
echo
echo ” 1.) Missing CA root certificates (make sure the ca-certificates package is installed)”
echo ” 2.) An old version of libssl. Try upgrading libssl on your system to a more recent version”
echo
echo “Contact support@packagecloud.io with information about your system for help.”
[ -e $yum_repo_path ] && rm $yum_repo_path
exit 1
elif [ “$curl_exit_code” -gt “0” ]; then
echo
echo “Unable to run: ”
echo ” curl ${yum_repo_config_url}”
echo
echo “Double check your curl installation and try again.”
[ -e $yum_repo_path ] && rm $yum_repo_path
exit 1
else
echo “done.”
fi

if [ “${os}” = “sles” ] || [ “${os}” = “opensuse” ]; then
finalize_zypper_repo
else
finalize_yum_repo
fi

echo
echo “The repository is setup! You can now install packages.”
}

main
===========================================
[root@git ~]#sh script.rpm.sh
Detected operating system as centos/7.
Checking for curl…
Detected curl…
Downloading repository file: https://packages.gitlab.com/install/repositories/gitlab/gitlab-ce/config_file.repo?os=centos&dist=7&source=script
done.
Installing pygpgme to verify GPG signatures…
Loaded plugins: fastestmirror
gitlab_gitlab-ce-source/signature | 836 B 00:00:00
Retrieving key from https://packages.gitlab.com/gitlab/gitlab-ce/gpgkey
Importing GPG key 0xE15E78F4:
Userid : “GitLab B.V. (package repository signing key) <packages@gitlab.com>”
Fingerprint: 1a4c 919d b987 d435 9396 38b9 1421 9a96 e15e 78f4
From : https://packages.gitlab.com/gitlab/gitlab-ce/gpgkey
gitlab_gitlab-ce-source/signature | 951 B 00:00:00 !!!
gitlab_gitlab-ce-source/primary | 175 B 00:00:00
Loading mirror speeds from cached hostfile
* base: mirrors.linode.com
* epel: mirror.cs.princeton.edu
* extras: mirrors.linode.com
* updates: mirrors.linode.com
Package pygpgme-0.3-9.el7.x86_64 already installed and latest version
Nothing to do
Resolving Dependencies
–> Running transaction check
—> Package yum-utils.noarch 0:1.1.31-40.el7 will be installed
–> Processing Dependency: python-kitchen for package: yum-utils-1.1.31-40.el7.noarch
–> Processing Dependency: libxml2-python for package: yum-utils-1.1.31-40.el7.noarch
–> Running transaction check
—> Package libxml2-python.x86_64 0:2.9.1-6.el7_2.3 will be installed
—> Package python-kitchen.noarch 0:1.1.1-5.el7 will be installed
–> Processing Dependency: python-chardet for package: python-kitchen-1.1.1-5.el7.noarch
–> Running transaction check
—> Package python-chardet.noarch 0:2.2.1-1.el7_1 will be installed
–> Finished Dependency Resolution

Dependencies Resolved

================================================================================================================================================
Package Arch Version Repository Size
================================================================================================================================================
Installing:
yum-utils noarch 1.1.31-40.el7 base 116 k
Installing for dependencies:
libxml2-python x86_64 2.9.1-6.el7_2.3 base 247 k
python-chardet noarch 2.2.1-1.el7_1 base 227 k
python-kitchen noarch 1.1.1-5.el7 base 267 k

Transaction Summary
================================================================================================================================================
Install 1 Package (+3 Dependent packages)

Total download size: 856 k
Installed size: 4.3 M
Downloading packages:
(1/4): libxml2-python-2.9.1-6.el7_2.3.x86_64.rpm | 247 kB 00:00:00
(2/4): python-chardet-2.2.1-1.el7_1.noarch.rpm | 227 kB 00:00:00
(3/4): yum-utils-1.1.31-40.el7.noarch.rpm | 116 kB 00:00:00
(4/4): python-kitchen-1.1.1-5.el7.noarch.rpm | 267 kB 00:00:00
————————————————————————————————————————————————
Total 3.7 MB/s | 856 kB 00:00:00
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
Installing : python-chardet-2.2.1-1.el7_1.noarch 1/4
Installing : python-kitchen-1.1.1-5.el7.noarch 2/4
Installing : libxml2-python-2.9.1-6.el7_2.3.x86_64 3/4
Installing : yum-utils-1.1.31-40.el7.noarch 4/4
Verifying : yum-utils-1.1.31-40.el7.noarch 1/4
Verifying : python-kitchen-1.1.1-5.el7.noarch 2/4
Verifying : libxml2-python-2.9.1-6.el7_2.3.x86_64 3/4
Verifying : python-chardet-2.2.1-1.el7_1.noarch 4/4

Installed:
yum-utils.noarch 0:1.1.31-40.el7

Dependency Installed:
libxml2-python.x86_64 0:2.9.1-6.el7_2.3 python-chardet.noarch 0:2.2.1-1.el7_1 python-kitchen.noarch 0:1.1.1-5.el7

Complete!
Generating yum cache for gitlab_gitlab-ce…
Importing GPG key 0xE15E78F4:
Userid : “GitLab B.V. (package repository signing key) <packages@gitlab.com>”
Fingerprint: 1a4c 919d b987 d435 9396 38b9 1421 9a96 e15e 78f4
From : https://packages.gitlab.com/gitlab/gitlab-ce/gpgkey

The repository is setup! You can now install packages.
[root@git ~]# yum -y install gitlab-ce
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: centos.mirror.nac.net
* epel: mirror.us.leaseweb.net
* extras: mirror.cc.columbia.edu
* updates: mirror.trouble-free.net
Resolving Dependencies
–> Running transaction check
—> Package gitlab-ce.x86_64 0:8.14.5-ce.0.el7 will be installed
–> Finished Dependency Resolution

Dependencies Resolved

================================================================================================================================================
Package Arch Version Repository Size
================================================================================================================================================
Installing:
gitlab-ce x86_64 8.14.5-ce.0.el7 gitlab_gitlab-ce 301 M

Transaction Summary
================================================================================================================================================
Install 1 Package

Total download size: 301 M
Installed size: 818 M
Downloading packages:
gitlab-ce-8.14.5-ce.0.el7.x86_64.rpm | 301 MB 00:00:48
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
Installing : gitlab-ce-8.14.5-ce.0.el7.x86_64 1/1
*. *.
*** ***
***** *****
.****** *******
******** ********
,,,,,,,,,***********,,,,,,,,,
,,,,,,,,,,,*********,,,,,,,,,,,
.,,,,,,,,,,,*******,,,,,,,,,,,,
,,,,,,,,,*****,,,,,,,,,.
,,,,,,,****,,,,,,
.,,,***,,,,
,*,.

_______ __ __ __
/ ____(_) /_/ / ____ _/ /_
/ / __/ / __/ / / __ `/ __ \
/ /_/ / / /_/ /___/ /_/ / /_/ /
\____/_/\__/_____/\__,_/_.___/
gitlab: Thank you for installing GitLab!
gitlab: To configure and start GitLab, RUN THE FOLLOWING COMMAND:

sudo gitlab-ctl reconfigure

gitlab: GitLab should be reachable at http://git.puppethub.in
gitlab: Otherwise configure GitLab for your system by editing /etc/gitlab/gitlab.rb file
gitlab: And running reconfigure again.
gitlab:
gitlab: For a comprehensive list of configuration options please see the Omnibus GitLab readme
gitlab: https://gitlab.com/gitlab-org/omnibus-gitlab/blob/master/README.md
gitlab:
It looks like GitLab has not been configured yet; skipping the upgrade script.
Verifying : gitlab-ce-8.14.5-ce.0.el7.x86_64 1/1

Installed:
gitlab-ce.x86_64 0:8.14.5-ce.0.el7

Complete!

[root@git ~]#gitlab-ctl reconfigure

git1.pnggit2.pnggit3.pnggit4.pnggit5.pnggit6git7git8git9

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s